Intercom is built and tested to work in the following web browsers. It may work in other browsers but these are not officially supported.

Web browser support for the Intercom app:

  • Chrome (Latest version*)
  • Firefox (Latest version*)
  • Safari 10 and later
  • Internet Explorer 11 and later

Web browser support for the Intercom Messenger:

  • Chrome (Latest version*)
  • Firefox (Latest version*)
  • Safari 8 and later
  • Internet Explorer 11 and later

Important: We don't support web sockets on older versions of Internet Explorer. 

If you find that you are using an outdated browser, you can upgrade it here. If you find issues in any of our supported browsers, please let us know by mailing us at team@intercom.com.

* Due to their 6-week release cycles, we only support the latest versions of Chrome and Firefox.

Intercom Conversations for iOS:

Requires iOS 10.0 or later.

Intercom Messenger for iOS:

Requires iOS 8.0 or later. Full documentation on required frameworks here

Intercom Conversations for Android: 

Requires Android API 21 (5.0) or later.

Intercom Messenger for Android:

Requires Android API 15 (4.0.3) or later. Full documentation on required frameworks here

TLS/SSL Best Practices.

We will update our TLS/SSL configuration from time to time and consider best practices / recommendations on a case by case basis. We err on the side of ensuring that communicating with Intercom is always secure, and so our TLS/SSL configuration may result in older or manually configured clients not being able to talk to Intercom. We announce TLS/SSL configuration changes as a "Product Update" in the Intercom application and for additional information about our TLS/SSL configuration please see our security page.

Did this answer your question?